Home > Cannot Open > Libgio 2.0 So 0 Cannot Open Shared Object File Firefox

Libgio 2.0 So 0 Cannot Open Shared Object File Firefox

Contents

So there's usually a 17 XUL to go along with 17 FF. I realise that I'm not using Arch's version of firefox (but I would if the language pack worked ) but I'm thinking there's just something I don't understand here about the Log Out Select Your Language English español Deutsch italiano 한국어 français 日本語 português 中文 (中国) русский Customer Portal Products & Services Tools Security Community Infrastructure and Management Cloud Computing Storage JBoss Join them; it only takes a minute: Sign up run firefox in redhat enterprise server 6 up vote 1 down vote favorite My box is redhat 64bit, i download firefox-17.0.1.tar.bz2, and my review here

This package is often rev'd at the same levels as firefox. and: > I doubt many users are going to add LD_LIBRARY_PATH=`pwd` to their command line. where else do you expect to find a "rooted" path? Maybe you can try what the user there is doing. https://bugzilla.mozilla.org/show_bug.cgi?id=1065337

Libgio-2.0.so.0 Rhel5

Maybe we should dupe this bug there. I also had same problem after a difficult upgrade from Mageia 2 to Mageia 3, 64bit. xulrunner should be added to the requirements for 64-bit Linux. (at http://www.seamonkey-project.org/releases/seamonkey2.15/#install) (probably would work for FF as well) Comment 26 Smeagol 2013-01-28 18:19:10 PST I still have the same problem

Are you new to LinuxQuestions.org? John VV View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by John VV 02-12-2012, 06:25 AM #6 threaderslash Member Registered: Dec 2008 I followed the instructions as mentioned in ths site. Libgtk-3.so.0: Cannot Open Shared Object File: No Such File Or Directory John VV View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by John VV 02-12-2012, 04:31 AM #4 threaderslash Member Registered: Dec 2008

I tried to upgrade the firefox to the latest version. Libgio-2.0.so.0: Cannot Open Shared Object File: No Such File Or Directory Couldn't Load Xpcom. Browse other questions tagged linux rhel firefox or ask your own question. Last Comment Bug1065337 - libgio-2.0.so.0 missing dependancy for CentOS-5 x86_64 (seamonkey-2.29.tar.bz2) Summary: libgio-2.0.so.0 missing dependancy for CentOS-5 x86_64 (seamonkey-2.29.tar.bz2) Status: UNCONFIRMED Whiteboard: Keywords: regression Product: SeaMonkey Classification: Client Software Component: General I had to remove many 32bit packages to allow the upgrade to procede.

With LD_LIBRARY_PATH, you can set this for only one program, e.g. Libgio Source How do I make an alien technology feel alien? OOOPS.... They hope these examples will help you to get a better understanding of the Linux system and that you feel encouraged to try out things on your own.

Libgio-2.0.so.0: Cannot Open Shared Object File: No Such File Or Directory Couldn't Load Xpcom.

So you're essentially stuck on this older version until Mozilla releases a newer version built with the older libraries support. http://serversabc.blogspot.com/2015/05/firefox-issuelibgio-20so0-cannot-open.html What is this line of counties voting for the Democratic party in the 2016 elections? Libgio-2.0.so.0 Rhel5 I know... Libgio-2.0.so.0 Centos 5 If I need to install FF 18 or above, I might be needing the corresponding 18XUL and above which is not provided by the current OS.

Totally dead? this page Summary: Program doesn't start: XPCOMGlueLoad error for libxpcom.so, Cannot load XPCOM. Why were pre-election polls and forecast models so wrong about Donald Trump? Johnson 2013-01-17 17:26:34 PST User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:18.0) Gecko/20100101 Firefox/18.0 Build ID: 20130104154505 Steps to reproduce: tried to start firefox 18.0 on CentOS-5.8 Linux, running latest Libgio-2.0.so.0 Not Found

There is no DYLD_LIBRARY_PATH on Linux, right? However, I was getting the error as {"XPCOMGlueLoad error for file /opt/firefox/libxul.so: libgio-2.0.so.0: cannot open shared object file: No such file or directory Couldn't load XPCOM."} –Ramesh Nov 25 '13 at Since then I noticed that a 64bit compile of Seamonkey is available further down on the download page, which I will use for future Seamonkey installs to avoid this sort of http://bestimageweb.com/cannot-open/libmysqlclient-so-cannot-open-shared-object-file.php Comment 7 Pierre Fortin 2011-11-22 10:49:06 PST I'll try this one later today...

You signed out in another tab or window. Yum Install Firefox LD_LIBRARY_PATH is the only relevant environmental variable? You just saved the day.

opensuse 13.1 RC1 Aurora 26 Comment 40 lainiwaku 2013-10-19 09:52:51 PDT lain@EVA:~$ /opt/firefox/firefox XPCOMGlueLoad error for file /opt/firefox/libxul.so: libdbus-glib-1.so.2: cannot open shared object file: No such file or directory Couldn't load

Do humans have an ethical obligation to prevent animal on animal violence? xulrunner i386 is present on both machines, so this may be why a different shared library is being flagged. Actual results: XPCOMGlueLoad error for file /usr/lib/firefox-18.0/libxpcom.so: libgio-2.0.so.0: cannot open shared object file: No such file or directory Couldn't load XPCOM. Firefox Linux Open Source Communities Subscriptions Downloads Support Cases Account Back Log In Register Red Hat Account Number: Account Details Newsletter and Contact Preferences User Management Account Maintenance My Profile Notifications Help Log

Note that ff doesn't say where it's looking for libXrender.so.1 (short of strace).... Where FF looks for libs may depend on whether you have "." in your $PATH. looks like I've confused you inadvertently... http://bestimageweb.com/cannot-open/libclntsh-so-10-1-cannot-open-shared-object-file.php I uninstalled the firefox and tried to install it without the package repository.

For more details see Persona Deprecated. Not the answer you're looking for? i stop at error like this, "XPCOMGlueLoad error for file /opt/firefox/libxpcom.so: libxul.so: cannot open shared object file: No such file or directory Couldn't load XPCOM." i look for solutions and learn Next step I tried proved this assumption. (Thanks :aceman for referencing to bug 723487 topic).

Although firefox then found its bundled libraries, it failed to find any system libraries. See comments in attached strace log.... Find More Posts by acid_kewpie 02-11-2012, 07:33 PM #3 John VV LQ Muse Registered: Aug 2005 Location: A2 area Mi. this specific file may be in the glib2 package).

Photographing Sea Turtles hatching on the beach Show that the square matrix A is invertible What does "there lived here then" mean? I've done this before but would not recommend running this way. I tried to upgrade using the packages for 5 version and when I did yum update firefox, it is saying me I have got the latest version already installed. –Ramesh Nov Comment 39 Raul Malea 2013-10-13 09:20:30 PDT XPCOMGlueLoad error for file /opt/aurora/libxul.so: libdbus-glib-1.so.2: cannot open shared object file: No such file or directory Couldn't load XPCOM.

Code blocks~~~ Code surrounded in tildes is easier to read ~~~ Links/URLs[Red Hat Customer Portal](https://access.redhat.com) Learn more Close current community chat Stack Overflow Meta Stack Overflow your communities Sign up or